Summary
In order for Okta to verify an account, the time on the phone must be synced properly to a time server. If not, the user will receive "invalid token" error.
Body
Problem
When attempting to add Okta Verify as a MFA credential, it gives a "Invalid Token" error.
Environment
iOS
Android
Resolution
Android
- Open your phone's clock app.
- Tap More in the upper right and then tap Settings
- To pick your home time zone: tap Home time zone.
- To automatically update your timezone: tap Change date & time and then Set time zone automatically.
- To update your timezone based on your location: tap Change date & time and then Set time zone automatically and then Use location to set time zone.
- To add a clock for home when you travel to another time zone: tap Automatic home clock.
iOS
- Go to Settings > General > Date & Time.
- Turn on any of the following:
- Set Automatically: iPhone gets the correct time over the network and updates it for the time zone you’re in. Some networks don’t support network time, so in some countries or regions, iPhone may not be able to automatically determine the local time.
- 24-Hour Time: (not available in all countries or regions) iPhone displays the hours from 0 to 23.
Cause
In order for Okta to verify an account, the time on the phone must be synced properly to a time server. If not, the user will receive "invalid token" error.