Body
Problem
When others receive emails from your Spartan Mail account, they do not see your name, but only your NetID as the sender.
Environment
Spartan Mail
Active MSU Students
Resolution
You will likely need to change restrictions that you may have placed on your directory information. For students, this will be done within the Student Information System, Campus Solutions. For faculty/staff, this will be done in Enterprise Business Systems (EBS).
This article has instructions how to enable and disable directory restrictions. Select a link below to jump to the relevant section:
Cause
This is usually caused by restrictions you have placed on your directory information.
If you have been graduated from MSU for more than 3 semesters, your email will also display in this format. That behavior cannot be changed.