Body
Problem
Even after:
- your student granted you access to their financial aid, and
- you registered your guest account, and
- logged in successfully to student.msu.edu,
you still don't see a tile for financial aid
Environment
SIS Campus Solutions
Resolution
Contact your student and have them delete and re-add your email account from student.msu.edu, matching the capitalization that you used to register the guest email address. Once the email addresses match, the next time you log in to student.msu.edu, the financial aid tile should appear. To delete and re-add your email account they should:
- Log in to student.msu.edu
- Select My Profile
- Select Share My Info Electronically
- Select Delete and confirm by selecting Yes - Delete
- Select Grant Access To A New Guest
- Select I Accept
- Enter your guest information, this time using the same capitalization in the Guest Email Address as what you used to register the account
- Select the View Financial Aid checkbox
- Select Save
Once your student does this, you should receive another email from sis that indicates access has been granted. You can then log in to student.msu.edu and the financial aid tile should now appear. If it still does not appear, please contact the Service Desk at (517)432-6200 for further assistance.
Other contact options for the IT Service Desk are available in the
Live Support Options section of the main
Client Portal page (link).
Cause
MSU Guest Account email addresses are case-sensitive when it comes to granting access in the financial aid portal. If there was a mismatch, the student will need to remove and re-add the account to match the capitalization exactly.