Keep Getting Sent Back to Login After Verifying Two Factor Authentication in SIS Campus Solutions

Problem

After logging in to student.msu.edu and entering the two-factor authentication (2FA) code, the user gets returned to the initial student.msu.edu login screen. The bounce back cycle will loop endlessly.

Environment

SIS Campus Solutions

Resolution

First make sure that access was granted at all. If the guest user never received a confirmation email, please follow the steps from Share My Info Electronically from the SIS help page

There are two places to check where the email address for the MSU Guest Account may have been used and could be causing the problem:

  • Campus Solutions
    • Have the student log in to student.msu.edu
    • Select the My Profile tile
    • Select Contact Details from the menu on the left
    • Check under Email and remove it if it matches the MSU Guest Account email address having issues
  • Okta (auth.msu.edu)
    • Have the student log in to auth.msu.edu
    • Select the menu with the student name at the top-right of the page
    • Select Settings
    • Under Personal Information, see if the MSU Guest Account email address is listed as the Secondary Email
      • Select Edit and remove the email address if necessary

After verifying that the MSU Guest Account email address has been removed from both places, try using it to log in to student.msu.edu again.

 

The student will also need to confirm that guest access was added in both locations within SIS:

  • under the My Profile tile, and
  • under the Financial Aid tile.

Access must be added in BOTH locations for the guest to be able to login and access the Financial Aid tile within SIS. More detailed instructions can be found here: Adding Guest Access in SIS.

  • SIS (student.msu.edu) - My Profile tile
    • Have the student log in to student.msu.edu
    • From the Student home page, select the My Profile tile
    • On the My Profile page, select Share My Info Electronically from the menu at the left
    • To add a new guest, select Grant Access to A New Guest
    • When the Share My Info - Terms and Conditions displays select I Accept
    • On the Share My Information - Details page, complete the following:
      • Guest Name
      • Guest Email Address
      • Confirm Guest Email Address
    • Under Transaction Name, check the box next to the item to which you are granting access.
    • Select Save
    • Select Ok on the confirmation message
  • SIS (student.msu.edu - Financial Aid tile
    • Have the student log in to student.msu.edu
    • From the Student home page, select the Financial Aid tile
    • Select Financial Aid Portal on the left menu
    • Select Open Financial Aid Portal
    • On the Financial Aid home screen, select your name in the top right corner and select Profile
    • On the Profile page, scroll down to the Manage Proxy Access section. If the status under Manage Proxy Access says "Pending," select Sign FERPA Form & Provide Consent
    • Scroll down on the consent form and enter your student ID and last name, then select Sign & Finish
      • Note: your student ID is your APID with a "1" in place of the "A"
        • Ex. A12345678 --> 112345678
    • In the Add/Edit Proxy Portal Access section, select the Add Guest icon (person with a plus sign)
    • Enter the Guest Email Address
    • Check the Proxy/Guest checkbox
    • Select Save

If none of the above has fixed the problem, contact the IT Service Desk by calling (517)432-6200 any time from 7 am to Midnight, 7 days a week

Cause

The email used for the MSU Guest Account may already be in use as an alternate email for the main student account.

 

Details

Article ID: 905
Created
Fri 3/17/23 6:54 PM
Modified
Wed 1/31/24 4:20 PM

Related Services / Offerings (1)