Transact Payments - Error Purchasing Items on iPhone Using Safari

Problem

Selecting the link to purchase an item on an iOS device will initially open a Safari preview window, shown below. The compass icon on the bottom-right is designed to open the link outside of the preview on the actual Safari application. Notice the preview Safari window shows a simplified version of the working URL (commerce.cashnet.com is not correct).

Selecting the compass icon results in an error: "An error has occurred. The problem has been logged for the system administrator."

Screenshot

Environment

Transacy Payments (formerly Cashnet)
iOS
Safari

Resolution

To work around this error:

  • The student can use the preview window to make the transaction, without ever selecting the compass icon.
  • The student can use a computer, in which there is no preview Safari window.
  • On an iOS device, the student can bypass the preview screen by holding the link (rather than tapping) and select the prompt to open in the Safari application directly.

This is what shows after holding down the link. Click on Open in Safari and it should open as normal to the correct page:

Screenshot

Cause

The compass link is incompatible with the iOS version of Safari.

 

Details

Article ID: 1301
Created
Wed 4/19/23 4:10 PM
Modified
Wed 1/17/24 3:19 PM

Related Services / Offerings (1)

Front end stores system for MSU Financial Transactions.