Spartan Mail - Error: "Sorry, but We're Having Trouble Signing You In"

Problem

When attempting to log in to your MSU email account using the Yahoo Mail App, you receive an error: "Sorry, but we're having trouble signing you in."

Screenshot

Environment

Yahoo Mail App
Spartan Mail

Resolution

You will need to use a different email client to access your MSU email. Please see How to Configure Email Clients in KB 1168 (link) for more details on acceptable email clients.

Cause

The Yahoo Mail client has been causing issues to linked accounts and has been blocked as a result.

Print Article

Related Services / Offerings (1)

Spartan Mail and related Spartan 365 software, including applications located at https://spartan365.msu.edu and downloaded Office applications (Word, Excel, PowerPoint, and Outlook), are provided to students while they attend the university and to faculty and staff members while they are employed by the university.