SPSS Premium - Server Login Box Pops Up and Prevents Application Launch

Problem

When trying to launch SPSS Premium on macOS a Server Login box pops up and prevents access to the application. Selecting Cancel closes the application and selecting OK appears to do nothing.

Screenshot

Environment

macOS 14.0 (Sonoma)
SPSS (Versions prior to 29.0.2.0)

Resolution

This issue has been fixed as of the 29.0.2.0 version of SPSS, which is now available for download at MSU.

  1. Force-close all instances of IBM SPSS.
  2. Visit https://msu.onthehub.com (link) and sign in using Single Sign-On.
  3. Select the drop-down arrow at the top-right next to where it says "Hello, <your name>" and choose Your Account/Orders.
    Screenshot
  4. Find your previous Order for the SPSS software and select View Details.
    Screenshot
  5. Select Download.
  6. Find the downloaded file and run though the installation normally.
    Screenshot
  7. You're done! SPSS should now be available to use.

Cause

A faulty library file appears to be the source of this issue. Version 29.0.2.0 (and later) contains fixed versions of this file.

Details

Article ID: 1891
Created
Fri 12/8/23 10:24 AM
Modified
Thu 1/11/24 4:12 PM