Virtual Private Network (VPN) - Fixing UAC Prompts When Connecting on Windows Devices

Problem

When attempting to connect to MSU's Virtual Private Network (VPN) you experience regular User Account Control (UAC) prompts disrupting the process.

Environment

Windows 11
Virtual Private Network (VPN)
Local Client Install

Resolution

To fix this problem, the VPN client must be a clean installation. Auto-update will not work. The steps to perform a clean install depends on if your machine is managed by System Center Configuration Manager (SCCM) and therefore has access to the Software Center, or if it doesn't. 

Software Center (Preferred)

MSU Employees with SCCM-managed Windows 11 devices should download the latest package from Software Center. This automatically removes all the existing components and performs a clean installation.

  1. Open the Start Menu and type: software center
  2. Select Software Center
  3. From the Applications tab on the left side, scroll down and select BIG IP Edge Client 72.26.0331.0528Uploaded Image (Thumbnail)
  4. Select InstallUploaded Image (Thumbnail)
  5. When the process completes:
    • the Install button should change to an Uninstall button,
    • Status will show "Installed", and
    • Version will show "72.26.0331.0528" (as of 7/16/26)Uploaded Image (Thumbnail)
  6. You're done! The local client has been uninstalled and reinstalled cleanly. Please let the IT Service Desk (ITSD) know if the problems persist after this fix.

Self-Managed Windows Devices

Users with administrative access on self-managed Windows computers can follow these steps. You must have administrator privileges to remove these components.

  1. Download the Windows Troubleshooting Utility from this link
  2. Find the downloaded file: f5wininfo.exe and open it
  3. Perform the Client Software Removal by selecting Tools and then Remove Components. A popup window will appear to confirm the removalUploaded Image (Thumbnail)
  4. Open a web browser and go to vpn.msu.edu
  5. Select Windows Client - Version 7.2.7 to download the latest versionUploaded Image (Thumbnail)
  6. Find the downloaded file: 7270_BIGIPWinEdgeClient.exe (as of 7/16/26) and open it
  7. Select InstallUploaded Image (Thumbnail)
  8. Accept the UAC prompt if one pops up
  9. Select FinishUploaded Image (Thumbnail)
  10. You're done! The local client has been uninstalled and reinstalled cleanly. Please let the IT Service Desk (ITSD) know if the problems persist after this fix.

Related Links:

Overview of the F5 Windows Troubleshooting Utility
Removing BIG-IP APM Client Components from Windows Systems
APM Client 7.2.7 Requires Clean Installation on Windows

Cause

Unknown

Print Article

Related Articles (3)

This will guide you through connecting a Windows device to the virtual private network (VPN) at MSU for the first time.
This article will cover the process of performing a Master Reset to resolve most VPN issues
The F5 Campus VPN is integrated with MSU's Unified Login (Okta), requires multi-factor Authentication (MFA), and also requires having anti-virus software installed.

Related Services / Offerings (1)

Virtual Private Network (VPN) is used to secure remote access to internal-only (non-public) services. MSU faculty and staff need to connect to trusted computing resources from remote networks across the general public Internet. ​​​​​​​VPN provides secure remote access and protects these communications across untrusted networks.