Problem
An account newly migrated to Spartan 365 suddenly gets bounceback errors saying "Delivery has failed to these recipients or groups". A good video about this issue is available on YouTube (link).
Screenshot
(graphic courtesy of Anexeon, LLC)
Environment
Spartan Mail
Resolution
There are two simple actions that solve most of the issues related to this problem.
If the Issues Persist
If you still encounter problems after performing the steps above, you can put single quotes around the email address (i.e. 'sparty@msu.edu') and your email will be sent out without using the "Type Ahead Cache".
Re-occurrence
It should be noted that email addresses can also be stored in old calendar events. If you update an old calendar event it may re-populate the "Type Ahead Cache" with the wrong information and recreate this issue. In this case you can simply delete the "Type Ahead Cache" entry again or you can update the calendar event by removing and re-adding the individual with the issue.
Cause
When you migrate an email account from a local exchange server to another exchange server or Office 365, you might encounter email bounce backs when using Outlook to send email to some people.
This is due to the way Microsoft Outlook stores the email addresses of people that you have emailed in the past. Outlook uses some information it has stored locally and attempts to deliver the message to the old server instead of the current location of the account.
For Administrators: