Fixing Delivery Errors (X500) in Spartan Mail (Office 365 and On Premise Exchange)

Problem

An account newly migrated to Spartan 365 suddenly gets bounceback errors saying "Delivery has failed to these recipients or groups". A good video about this issue is available on YouTube (link).

Screenshot

Environment

Spartan Mail

Resolution

There are two simple actions that solve most of the issues related to this problem.

  • When you start typing an email address, suggestions appear automatically. When the person appears, delete the entry from the "Type Ahead Cache" in Outlook before sending the email by clicking the "x" to the right of the name and then try again.
    Screenshot
  • Delete and re-add the contact if you created a contact for the person.
    Screenshot

If the Issues Persist

If you still encounter problems after performing the steps above, you can put single quotes around the email address (i.e. 'sparty@msu.edu') and your email will be sent out without using the "Type Ahead Cache".

Re-occurrence

It should be noted that email addresses can also be stored in old calendar events. If you update an old calendar event it may re-populate the "Type Ahead Cache" with the wrong information and recreate this issue. In this case you can simply delete the "Type Ahead Cache" entry again or you can update the calendar event by removing and re-adding the individual with the issue.

Cause

When you migrate an email account from a local exchange server to another exchange server or Office 365, you might encounter email bounce backs when using Outlook to send email to some people.

This is due to the way Microsoft Outlook stores the email addresses of people that you have emailed in the past. Outlook uses some information it has stored locally and attempts to deliver the message to the old server instead of the current location of the account.

For Administrators:

Details

Article ID: 937
Created
Sat 3/18/23 12:37 PM
Modified
Wed 5/17/23 1:59 PM

Related Services / Offerings (1)

Spartan Mail and related Spartan 365 software, including applications located at https://spartan365.msu.edu and downloaded Office applications (Word, Excel, PowerPoint, and Outlook), are provided to students while they attend the university and to faculty and staff members while they are employed by the university.