Calls Not Ringing Through From EC500 to a Cell Phone

Problem

Calls are not ringing through to a cell phone despite EC500 being enabled and the phone number is correct.

Environment

EC500

Resolution

To resolve this issue, turn off the privacy setting which blocks these numbers. Once the setting is turned off, calls should route through normally.

Android Devices

The steps and settings to block/unblock numbers or callers on Android devices vary by manufacturer and device. You may need to consult their documentation. For example, Samsung has published guidance for their Galaxy devices on samsung.com (link).

Apple Devices

From Apple Support (link):

  • On the iPhone, go to Settings > Phone.
  • Find the slider for Silence Unknown Callers and switch it off.

Cause

Cell phones have privacy settings which may prevent private, restricted, and/or unknown numbers from ringing through. EC500 fails completely if these settings are enabled.

Details

Article ID: 1292
Created
Wed 4/19/23 3:31 PM
Modified
Mon 7/31/23 3:39 PM

Related Services / Offerings (1)

MSU provides telephone services and need-specific telephone systems throughout campus.