Problem
When attempting to connect to the VPN you get a message that you have failed the anti-virus check.
Environment
Virtual Private Network (VPN)
Resolution
- Verify the computer's anti-virus program is an approved program: What Do I Need Before I Can Use the VPN at MSU (link, KB 36).
Note that the included anti-virus programs on modern macOS and Windows computers are approved programs, and those computers generally do not require additional anti-virus programs. However Windows Defender is disabled if other anti-virus programs are installed. In such cases verify that the third party anti-virus program is enabled and running.
- When prompted during the connection, make sure to click to allow the Run Endpoint Inspector prompt.
- Verify only one anti-virus program is installed and running.
- Uninstall any expired or older anti-virus programs.
- Verify only one reputable anti-virus program is installed.
- Quit the BIG-IP Edge Client program or disconnect from vpn.msu.edu.
- Restart the computer.
- Re-open the BIG-IP Edge Client program or vpn.msu.edu and try connecting again.
Cause
This can be caused by anti-virus programs that are incompatible with the VPN, are failing to run, or are interfering with each other.