Spartan 365 - Spartan Mail Only Shows My NetID as the Sender and Not My Full Name

Problem

When others receive emails from your Spartan Mail account, they do not see your name, but only your NetID as the sender.

Environment

Spartan Mail
Active MSU Students

Resolution

You will likely need to change restrictions that you may have placed on your directory information. See this article (link) for instructions how to enable/disable restrictions on your directory information.

Cause

This is usually caused by restrictions you have placed on your directory information.

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Related Articles (1)

Following these steps will allow you to modify how your information appears in the directory, or prevent it from appearing at all.

Related Services / Offerings (2)

MSU NetIDs are assigned to all current faculty, staff, students and retirees. A NetID is a unique alphanumeric identifier auto-generated from the user's name. Your NetID is your personal identifier at MSU and serves as your login to many university computing and networking services. Your NetID also determines your MSU email address which is netid@msu.edu (e.g. the NetID msuspartan would have the email address msuspartan@msu.edu).
Spartan Mail and related Spartan 365 software, including applications located at https://spartan365.msu.edu and downloaded Office applications (Word, Excel, PowerPoint, and Outlook), are provided to students while they attend the university and to faculty and staff members while they are employed by the university.