Spartan 365 - Error in Office365 on Mac - "Your account doesn't allow editing on a mac"

Problem

When opening Office applications, the files open in read-only mode and there is an error across the top saying either: "Your account doesn’t allow editing on a Mac” or “Activate Microsoft 365 to Create and Edit”.

Environment

macOS
Office 365

Resolution

MacOS users occasionally run into the error "Your account doesn't allow editing on a Mac" when trying view/edit files in Office365.  This can occur with brand new installs and existing setups that were, prior to now, working fine.
Resolving this error is a mixture of different tasks.  Analysts should start with the simplest ones, with software uninstall/reinstall being a last resort due to both time and network data requirements.

NOTE: Before proceeding, always verify that the user is an active student, faculty, staff, or authorized affiliate with the necessary 'Office 365 ProPlus' license assigned to them in Tools365.  The current license type for these installs should be A3 or A5. Alumni, retirees, and typical Affiliates/Adjuncts will not have this license by default.

Affected users should try these steps

  1. Log out of all applications & log back in.  Make sure to sign in with MSU credentials.  The account type is Work/School.
  2. Log out of all applications & restart the computer.  Log back in and restart Office.
  3. Update Office365 applications and repeat the previous steps as needed.
  4. Check Office365 License with the IT Service Desk (this should be completed at the beginning of the call).
  5. Go to the [Library] folder in Finder and open Group Containers. CTRL+click each of these folders if present, and Move to Trash.
    UBF8T346G9.ms
    UBF8T346G9.Office
    UBF8T346G9.OfficeOsfWebHost
    Close all applications. Restart. Log out of the MSU Office account and then log back in.
    \\Source >> https://answers.microsoft.com/en-us/msoffice/forum/all/your-account-doesnt-allow-editing-on-a-mac-to/0df4e014-c77e-4d1b-ba12-1d13550ca7d8
  6. Remove all Microsoft related keychains and activate Office again. To do that:

    i. Open Finder > Applications > Utilities > Keychain Access
    ii. Choose All Items in Category, and search Microsoft in the upper-right search box.
    iii. Delete all the keychains if present.
    iv. Launch Office again and sign in using your MSU email address and password.

    This article (link) on support.apple.com describes the process to delete keychains
     
  7. Remove any existing Office license files from the MacOS computer using the Mac License Removal Tool.
    >> https://support.microsoft.com/en-gb/office/how-to-remove-office-license-files-on-a-mac-b032c0f6-a431-4dad-83a9-6b727c03b193
     

If these steps do not fix the problem, it may be a licensing issue. Contact the IT Service Desk at (517)432-6200 to verify your licensing.

You may also try completely uninstalling Office 2016 for Mac including removing support files and keychain entries following this article: Troubleshoot Office 2016 for Mac issues by completely uninstalling before you reinstall (link). Then reinstall it from the Office 365 portal at http://portal.office.com/OLS/MySoftware.aspx.

Cause

Sometimes saved passwords in the Apple keychain can cause problems authenticating to use licensed Office365 software.  Licensing file errors and older versions of Office365 may also trigger this error.

Details

Article ID: 1719
Created
Thu 4/27/23 4:37 PM
Modified
Wed 4/17/24 11:23 AM

Related Services / Offerings (1)

Spartan Mail and related Spartan 365 software, including applications located at https://spartan365.msu.edu and downloaded Office applications (Word, Excel, PowerPoint, and Outlook), are provided to students while they attend the university and to faculty and staff members while they are employed by the university.