Spartan Mail - Connection Seems Slow or Shared Calendars Are Not Updating

Problem

Using the standard Windows Outlook setup configuration for Spartan Mail (available in KB 758 (link)) results in slower than normal connections or you notice that your calendar or shared calendars aren't updating.

Environment

Spartan Mail
Locally installed Outlook client
Windows

Resolution

Turning off cache mode for Outlook may help.

To turn off cache mode:

  1. Open the File menu and select Accounts.
  2. Select the down arrow on Account Settings and then choose Account Settings.
    Screenshot
  3. Double-click your account to open the Exchange Account Settings.
    Screenshot
  4. Un-check the box next to Use Cached Exchange Mode to download email to an Outlook data file.
    Screenshot
  5. Select Next.
  6. Select Done.
  7. Restart Outlook.
  8. You're done! You've turned off cache mode for your local Windows Outlook client.

Cause

The caching process may be causing slowdowns and even preventing certain calendars from updating promptly. Disabling it removes this possibility.

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Related Services / Offerings (1)

Spartan Mail and related Spartan 365 software, including applications located at https://spartan365.msu.edu and downloaded Office applications (Word, Excel, PowerPoint, and Outlook), are provided to students while they attend the university and to faculty and staff members while they are employed by the university.