Error: "Password Requirements Not Met" When Trying to Reset NetID Password

Problem

When passwords are close to expiring, you are prompted to reset them. Sometimes, after this reset, the prompt comes right back up asking to reset the password again. Any password attempted for the reset after that point results in an error: "Password requirements not met".

Screenshot

Environment

Okta

Resolution

The password was actually successfully reset the first time. Select Not Now on the new prompt that came up to bypass the process. You can then continue and use the new password that you just reset. If you cannot remember the password that you attempted for the reset, your options are limited:

Cause

Okta prohibits an end user from resetting their own password more than once in a 24 hour period. Browser cache issues may be what causes the prompt to keep coming back. See this article (KB link) for instructions to clear your browser cache.

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Details

Article ID: 1128
Created
Thu 3/23/23 11:07 AM
Modified
Thu 11/9/23 7:11 PM

Related Services / Offerings (2)

MSU NetIDs are assigned to all current faculty, staff, students and retirees. A NetID is a unique alphanumeric identifier auto-generated from the user's name. Your NetID is your personal identifier at MSU and serves as your login to many university computing and networking services. Your NetID also determines your MSU email address which is netid@msu.edu (e.g. the NetID msuspartan would have the email address msuspartan@msu.edu).