Network - Troubleshooting Guide for Windows and macOS Devices Receiving 169.* IP Addresses

Problem

A device is unable to connect to the network successfully and is receiving an IP address beginning with 169 (169.x.x.x).

Environment

Windows
macOS

Resolution

Check for IP blocking software on both Windows and Mac computers

PeerGuardian, IceClean and similar IP blocking applications can cause the computer to get a 169.* address; this is usually the case when you encounter 169.* on a Mac computer. If you have IP blocking software installed on your device, try disabling it and seeing if you get a valid connection after doing so.

 

Further Windows troubleshooting

A 169.x.x.x IP address is generally related to a connectivity issue. Steps to troubleshoot the issue are as follows:
  • For wired connections, verify the the ethernet cable is connected.
    • See if a message pops up when cable is connected. If there is something wrong with the connection, Windows will display an error message along the lines of "Limited or no connectivity..."
  • Verify the IP address:
    1. Click on Start.
    2. Click on Run...; type cmd
    3. When the Command Prompt opens, type ipconfig
      • If the IP Address is a 169.x.x.x, then it is an invalid IP address. Continue with the troubleshooting instructions below.
      • If you instead get a 192.x.x.x, 10.x.x.x, or 176.x.x.x IP address, then it may be a router issue.
  • Release and Renew your IP Address:
    1. Click on Start.
    2. Click on Run...
    3. When the Command Prompt opens, type ipconfig /release. You should see the IP address now set to 0.0.0.0
    4. Now type ipconfig /renew. You should see the IP address be set to 35.x.x.x.
  • Reinstalling the Drivers
    • Verify that the Ethernet cable is connected.
    • Go to Start->Control Panel.
    • When the Control Panel has loaded, select System.
    • Click on the Hardware tab.
    • Click on the Device Manager button to open the Device Manager window.
    • Under network adapters, disable any wireless adapters.
    • Right-click on the network adapter and select Uninstall
    • Right-click on the network adapters and select Scan for hardware changes to reinstall the driver.
After the correct adapter is installed you could try restarting the PC (easiest method) or waiting a minute for the computer to detect the connection. Then try: IPCONFIG /RELEASE and: IPCONFIG /RENEW to attempt to obtain a 35.x.x.x address. If you do, you are all set.

Cause

A 169.x.x.x IP address indicates a connectivity problem.

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