Error: "There Was a Problem Processing Authentication, Either Username or Password Was Invalid or Your Account Does Not Exist" (D2L)

Problem

When you attempt to log in to D2L, you receive an error: "There Was a Problem Processing Authentication, Either Username or Password Was Invalid or Your Account Does Not Exist".

Environment

D2L

Resolution

There is a delay in user information getting added to D2L. Check your status against the timeframes listed below:

Type of Account Expected Delay
Student 1-4 business days after enrollment
MSU Guest Account 15 minutes to 1 business day after enrollment
Faculty / Staff Current appointment, or designated Future Faculty by the ID Office, 1-2 business days after appointment/designation

If you are past the expected delay period:

  1. Try clearing your browser's cookies / cache. Close and re-open the browser after doing so.
  2. If you still cannot log in, then contact the IT Service Desk for assistance.

Cause

This error indicates the password is correct, but the account does not yet exist in D2L.

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Learning Management Systems (LMS) provides support and troubleshooting for MSU’s LMS platforms, including D2L (Desire2Learn) and other related tools. The service covers user inquiries, technical issues, and guidance on LMS features such as course creation, content management, assessments, grading, and communication tools.
Learning Management Systems (LMS) provides support and troubleshooting for MSU’s LMS platforms, including D2L (Desire2Learn) and other related tools.
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